思科交换机snmp配置命令,思科交换机命令行

思科交换机命令

思科交换机命令

最好到官网下载对应型号的说明书。入门的话,市面上很多教程都是基于思科的,但到了实际应用中有些功能可能对应机型不能应用 ,最好就是到官网下载说明书

思科交换机配置命令

思科交换机配置命令

http://www.cisco.com/cisco/web/psa/configure.html
这是cisco给的所有交换机的配置命令,你要什么都可以找到
product – switches– 再选择你要的型号
http://www.cisco.com/cisco/web/CN/psa/configure.html
上面的链接是思科中国的网站给的,有中文资料。在产品——交换机里面选择你需要的配置。

思科交换机的所有命令?

思科交换机的所有命令?

Switch>enable //一般模式
Switch#configure terminal //特权模式
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface fastEthernet 0/2 //进入端口
Switch(config-if)#switchport mode access //该端口设置成二层模式
Switch(config-if)#switchport access vlan 10 //划入VLAN10
Switch#show vlan //类似一张身份证

思科交换机的命令解释?

思科交换机的命令解释?

3560_1(config)#interface range g1/1-2 ///进入接口组 g1和g2(千兆接口)
3560_1(config-if)#switch trunk enc dot1q ////(g1和g2)接口封装模式设置为802.1q
3560_1(config-if)#switch mode trunk ////(g1和g2)接口模式设置为干道模式(与交换机互联)
3560_1(config-if)#channel-group 2 mode on ////绑定以太网通道(把两条物理链路绑定为一条逻辑的链路,从而增加带宽,两条千兆接口的链路绑定后就为一条2千兆的链路),组号为2
3560_1(config)#spanning-tree vlan 50 root primary ////设置交换机为vlan50的生成树主根(PVST+协议)
3560_1(config)#spanning-tree vlan 51 root secondary ////设置交换机为vlan51的生成树次根(PVST+协议)
3560_1(config)#int vlan 50 ////进入vlan50的SVI(虚接口)
3560_1(config-if)#ip add 182.168.50.2 255.255.255.0 ////配置IP(这个不用说了吧)
3560_1(config-if)#standby 3 ip 182.168.50.1 //G3的虚地址 (配置vlan50的HSRP热备份路由的虚拟网关地址)
3560_1(config-if)#standby 3 pri 150 //设置优先级,默认为100 (很明显这台三层交换机是vlan50的活跃路由,只要是vlan50的数据包,都是由这台三层交换机来转发的)
3560_1(config-if)#standby 3 preempt //配置抢占(这个也不用说吧,不配的话,它不会抢)
3560_1(config-if)#standby 3 track g0/48 90 //跟踪上联链路,down后,优先级降90
3560_1(config)#int vlan 51 ////进入vlan50的SVI(虚接口)
3560_1(config-if)#ip add 182.168.51.3 255.255.255.0
3560_1(config-if)#standby 4 ip 182.168.51.1 (配置vlan51的HSRP热备份路由的虚拟网关地址)
3560_1(config-if)#standby 4 preempt //////配置占先权(这台交换机为vlan51的网关备份路由设备)
3560_1(config)#udld aggsive //开启udld,并设置为aggsive模式,产生单通就down
3560_1(config)#interface range g1/1-2
3560_1(config-if)#udld port aggsive //接口开启udld
这是一个非常经典的解决方案,希望你要理解每条命令的作用,还有协议的工作机制

谁帮忙给个思科交换机的查询命令?

谁帮忙给个思科交换机的查询命令?

第一个问题:知道IP地址的情况:在网关上使用 show arp | in 1.1.1.1 命令查看MAC地址,然后使用show mac-address-table | in aaaa.bbbb.cccc 命令查看从那个接口学到MAC地址,然后使用 show cdp nei f0/0(学到MAC地址的接口),登录到对端设备在重复show mac-address-table | in aaaa.bbbb.cccc命令,就能知道最终在那个接口学到的。
知道MAC地址情况:使用show mac-address-table | in aaaa.bbbb.cccc命令,然后使用 show cdp nei f0/0(学到MAC地址的接口),登录到对端设备在重复show mac-address-table | in aaaa.bbbb.cccc命令,就能知道最终在那个接口学到的。
第二个问题:举例 IP地址1.1.1.1 MAC aaaa.bbbb.cccc 查看F0/24接口学到的MAC和IP地址。使用命令 show mac-address-table | in 0/24,会显示从F0/24接口学到的MAC地址,然后在网关上使用show arp | in aaaa.bbbb.cccc 命令查看对应的IP地址。

原创文章,作者:聚禄鼎,如若转载,请注明出处:https://www.xxso.cn/3476.html

发表评论

邮箱地址不会被公开。 必填项已用*标注